verdwenen foto's

In dit topic
viewtopic.php?f=36&t=34953&start=500#p387736
plaatste ik een opmerking die terecht als flauw werd aangemerkt.

Ik heb geprobeerd de oorzaak te achterhalen, maar ik begrijp het niet.

Op mijn Samsungtablet gebruik ik standaard Firefox als browser.
Als ik naar het genoemde bericht ga zie ik dit (met excuus voor de kwaliteit, maar ik kan geen screendump maken van de tablet)
beeldschermtablet.jpg
Bekijk ik op de tablet het bericht met de Samsung-browser, zie ik het normale bericht met de foto's.

In het bericht waarin Carl mijn bericht citeerd,
viewtopic.php?f=36&t=34953&start=520#p387786
zie ik de foto's wel in Firefox.

Ik heb gekeken naar de codes waarmee de foto's door Michiel worden geplaatst. En dan valt iets op:

Het is geen normale link naar een foto.
Tussen de img-codes staat:
https ://scontent-ams4-1.xx.fbcdn.net/v/t1.0-9/157168375_1593349660864235_5303589835407663735_o.jpg?_nc_cat=110&ccb=3&_nc_sid=730e14&_nc_ohc=9-92KLYckbMAX_8ZsQg&_nc_ht=scontent-ams4-1.xx&oh=45da4f67be44ebf4a6d55210590313b3&oe=60669BFB

Deze code is door Firefox op de tablet blijkkbaar niet leesbaar.

In het bericht van Carl, waarin mijn bericht wordt gequote staat de code:
https ://scontent-ams4-1.xx.fbcdn.net/v/t1.0-9/157168375_1593349660864235_5303589835407663735_o.jpg?_nc_cat=110&ccb=3&_nc_sid=730e14&_nc_ohc=9-92KLYckbMAX_8ZsQg&_nc_ht=scontent-ams4-1.xx&oh=45da4f67be44ebf4a6d55210590313b3&oe=60669BFB

Voor zover ik de brij aan tekens kan overzien zijn deze twee codes identiek. Maar in het gequote bericht zijn de foto's door Firefox wel te vertalen.

Kijk ik naar een ouder bericht van Michiel zie ik dat zijn foto's op een maar klassieke manier in het bericht zitten.
Een willekeurige foto uit een ouder bericht:

http :// www. sintchristophorus.nl/wp-content/comment-image/157860.jpg

Wie het begrijpt mag het zeggen.

Edit:
Vermoedelijk zit het verschijnsel er in dat in het bericht met de lange beeldcode, verwezen wordt naar een foto op Facebook. En daar ontstaan dan problemen met de koppeling tussen Firefox en Facebook. Waarom het wel goed gaat in een gekwoot bericht blijft raadselachtig.

Edit 2:
Om de volledige code van de foto's leesbaar te maken in dit bericht heb wat spaties toegevoegd in de codes.
Anders verschenen ze als aanklikbare link in het bericht.
Peter Molog schreef:
vr 05 mar, 2021 11:46
In dit topic [...] plaatste ik een opmerking die terecht als flauw werd aangemerkt.

Ik heb geprobeerd de oorzaak te achterhalen, maar ik begrijp het niet.
Tsja, die oorzaak zul je toch echt bij jezelf moeten zoeken :lol:

EDIT: sorry, zonder achtergrondkennis is je opmerking erg vermakelijk.
Serieus: het woord "Afbeelding" wordt getoond als Firefox het bestand niet kan of wil downloaden. Dat eerste zou ook kunnen als Facebook het bestand niet wil leveren. Ben je zelf ingelogd op Facebook?

De url bestaat uit twee delen, het afbeeldingsbestand zelf:

https ://scontent-ams4-1.xx.fbcdn.net/v/t1.0-9/157168375_1593349660864235_5303589835407663735_o.jpg

En achter het vraagteken allerlei parameters waarmee Facebook je bijvoorbeeld probeert te tracken, of de toegang controleert:

?_nc_cat=110
&ccb=3
&_nc_sid=730e14
&_nc_ohc=9-92KLYckbMAX_8ZsQg
&_nc_ht=scontent-ams4-1.xx
&oh=45da4f67be44ebf4a6d55210590313b3
&oe=60669BFB

Als ik ook maar iets aanpas aan een van de parameters krijg ik een foutmelding terug: Bad URL timestamp, URL signature mismatch, ...
eindgebruiker schreef: EDIT: sorry, zonder achtergrondkennis is je opmerking erg vermakelijk.
???????????

Sorry hoor.
Er valt mij een technische onvolkomenheid op en ik probeer dat uit te zoeken. En ik ben geen specialist op het gebied van website-ontwerp. In mijn ongetwijfeld knullige bewoordingen probeer ik te verwoorden wat ik zie. Vooral als verklaring waarom ik in de ogen van veel mensen, en daar hadden ze gelijk in, een flauwe opmerking maakte.

En ingelogd op Facebook?
Neen, dat soort onzin doe ik niet aan.
Update: met Firefox op mijn HTC smartphone werkt het gewoon, maar met Firefox op mijn Samsung tablet worden de afbeeldingen niet getoond, noch in het origineel van Christophorus, noch in het geciteerde bericht. Niet ingelogd op Facebook.
Het verschil blijkt te zitten in "Instellingen > Verbeterde bescherming tegen volgen". Als die op Streng staat, krijg ik geen afbeeldingen vanaf Facebook te zien, als die op Standaard staat wel.
Dank voor deze antwoorden.

Peter
Peter Molog schreef:
vr 05 mar, 2021 11:46
In het bericht van Carl, waarin mijn bericht wordt gequote staat de code:
Let op: de plaatjes in mijn bericht hebben technisch natuurlijk niks te maken met de afbeeldingen van Christophorus hè. Het zijn screenshots van hoe ik jouw bericht zie (in Firefox 86.0 64-bit onder Windows10, als dat iemand verder helpt), geüpload vanaf mijn eigen pc.

Groetjes,

Carl
Carl schreef: Let op: de plaatjes in mijn bericht hebben technisch natuurlijk niks te maken met de afbeeldingen van Christophorus
Je hebt helemaal gelijk!!!
had beter moeten opletten.🙈
Tip: ik raad sowieso af om Facebook plaatjes-URLs te gebruiken in het forum. Naar mijn ervaring verdwijnen die na een periode van een paar weken. Liever uploaden op het forum zelf.